• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

If you WysiwygPlugin to a page that does not exist, should it give you a blank page?

because I get the contents of "This page does not exist"

--MC

it needs some sort of trap to prevent you kupu-editing a blank page or rather, persauding TWiki to serve something other that the page create page when you edit a new topic I have a solution, now I think about it, but it'll only work with Dakar

http://koala.ilog.fr/twikiirc/bin/irclogger_log/twiki?date=2005-11-14,Mon&sel=484#l480

CC

It didn't use to do it - here's an old installation:

http://testwiki.mrjc.com/twiki/bin/edit/Sandbox/?topic=FooBarFum&templatetopic=WebTopicEditTemplate&onlywikiname=on&onlynewtopic=on&skin=kupu

Its running 6827 of the plugin and 7245 of lib/TWiki.pm

CC

That said, I just rolled out to a parallel location last week's build of my production site. It too has the error! (Am very surprised!)

Some weird anomally must cause the difference.

I'd very much appreciate if you could share your solution.

Thanks. MC

Hmmm. I just tried it with a non-existant topic (SVN 7460) and somewhat to my surprise it serves up an empty document, which is the desired behaviour. You can verify this with a URL like this:

http://localhost/DEVELOP/bin/view/Sandbox/BlahBlahBlah?skin=kupu;wysiwyg_edit=1
This is like the URL that the editor uses to recover the content to be edited. if this serves a new topic screen, then it's broken. If it serves a blank page, you are cooking with gas.

I haven't tried it with Cairo yet.

CC

Did you really mean view?

I tried it with both view and edit. as soon as I add the wysiwyg_edit=1 the browser returns nothing.

MC

Are you doing a pseudo-install or one from zip? I know it should not make any difference.

MC

Yes, I meant view. It works like this:

  1. User invokes "edit"
  2. Edit script populates the kupu.edit.tmpl template. This template contains an IFRAME that has src="http://localhost/DEVELOP/bin/view/Sandbox/BlahBlahBlah?skin=kupu;wysiwyg_edit=1".
  3. During onLoad in the browser, this URL is queried for the edited content
Since a view of a non-existant topic is simply redirected to an edit, it works just the same. But this time the topic doesn't exist, so the WysiwygPlugin makes view return the null string and the edit starts up on the resulting "blank" page.

CC

Thanks.

And are you using pseudo-install?

MC

yes

CC

I think this is a bug caused by NatSkinPlugin - as if I turn off this plugin then the problem goes away.

MC

Which other plugins are installed while reproducing this error? I was able to get similar erroneous behavior when switching on the TwistyPlugin. See bug Item977 which has already been recasted from NatSkinPlugin to WysiwygPlugin. There is a problem with the way kupu uses the onload event which interferes with the addLoadEvent() of other plugins like the TwistyPlugin and NatSkinPlugin. I fear that the above error is caused along the same lines..

MD

Can someone confirm if this bug is still valid given that Item977 is closed already?

MD

Since SVN 7780 the NatSkinPlugin disables itself when used with another skin (see Item1130). I tested the kupu editor and things seem to be fine now. Can anybody else who had problems before confirm that this bug is fixed now, please? See also Item1127.

MD

Nobody complains anymore, so I closed it.

MD

ItemTemplate
Summary WysiwygPlugin has erronous content when creating new topic if NatSkinPlugin is installed
ReportedBy MartinCleaver
SVN Range

AppliesTo Extension
Component NatSkinPlugin
Priority Normal
CurrentState Closed
WaitingFor

Edit | Attach | Watch | Print version | History: r14 < r13 < r12 < r11 < r10 | Backlinks | Raw View |  Raw edit | More topic actions
Topic revision: r14 - 2005-12-20 - MichaelDaum
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2022 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback