• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item5120: Conflicts with DBCachePlugin in regards to new line treatment

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Extension EditRowPlugin Normal No Action Required TWiki:Main.LynnwoodBrown n/a  

Edit Form Data

Reported By:
Applies To:
Current State:
Waiting For:
Target Release:
Released In:


When formatting DBQUERY results as a table, an extra line gets added between each row, breaking the table. You can see an example of the results in this image:


I brought this up with MD and he mentioned a conflict between EditRowPlugin and DBCachePlugin. I'm not saying the problem is in one or the other (although the problem does not exist with EditTablePlugin), but would like to see if we can figure out what's happening.

-- TWiki:Main/LynnwoodBrown - 12 Dec 2007

I tried your suggestion, but failed. Then I setup a completly new TWiki and only installed the TopicClassificationPlugin and it's dependencies and surprisingly the tables weren't broken any more ... The I installed EditRowPlugin and editTablePlugin and it worked, too!!! The next step was that I deactivated all Plugins in the TWiki where the tables were broken, exept those for TopicClassificationAddon and the tables worked!! Slowly adding one Plugin after the other showed that the Plugin TopicCryptPlugin kills the table. Don't ask me what these two Plugins have in common that they interfere that much, but deactivatiing this Plugin solved the problem ...

-- TWiki:Main.WolfgangBertl - 14 Dec 2007

Well, that stumps me. In my testing, it worked with EditTablePlugin but did not work with EditRowPlugin. BTW, did you have both EditTablePlugin and EditRowPlugin? If that was the case, than I suspect that EditTablePlugin was the one processing the tables because it would load after than EditRowPlugin. I'm not sure plugins work like that and I'll try to ask someone who would know. I have no idea bout TopicCryptPlugin as I've never used it.

-- TWiki:Main.LynnwoodBrown - 20 Dec 2007

Hello, I tried all variations. I tried with EditTablePlugin together with EditRowPlugin and I tried them separately, all did not work for me. Since I switched of the TopicCryptPlugin, ist works fine. No idea why ...

-- TWiki:Main.WolfgangBertl - 20 Dec 2007

Pitching the ball back to Lynnwood ....



-- TWiki:Main.CrawfordCurrie - 07 May 2008

I think this bug is no longer relevant being as features of EditRowPlugin have been incorporated into EditTablePlugin. Also, I have not observed this problem in some time.

-- LynnwoodBrown - 25 Jun 2008

Summary Conflicts with DBCachePlugin in regards to new line treatment
ReportedBy TWiki:Main.LynnwoodBrown

SVN Range TWiki-4.3.0, Sun, 25 Nov 2007, build 15790
AppliesTo Extension
Component EditRowPlugin
Priority Normal
CurrentState No Action Required
WaitingFor TWiki:Main.LynnwoodBrown

TargetRelease n/a

Edit | Attach | Watch | Print version | History: r7 < r6 < r5 < r4 < r3 | Backlinks | Raw View |  Raw edit | More topic actions
Topic revision: r7 - 2008-06-25 - LynnwoodBrown
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2023 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback