• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.
Add this into a form field: Testing "quoted text" content

After an edit/save cycle this is left: Testing

This is a serious bug that prevents me from updating to Dakar.

-- PTh

Hmm, it seems to work here. Actually, I used

to add a comment to an existing topic that happens to have a TWiki form.

-- PTh

I tried to reproduce it at TestTemplate? but could not. Apparently it happens with a 1.0 format topic that gets converted to 1.1 format.

-- PTh

Please attach a topic with the 1.0 format that get's garbled (check previous revision of the topic you're using) so we can properly test.

-- RA

See attached tt.zip file. Also copied on this server to DocForm? , DocID1? , DocID2? .

-- PTh

Locally, %_Q_% is changed into %22 when I save it here, but nothing is lost per se.

Before / after:

Perhaps this has to do with I18N setup?

My I18N-related settings are:

$TWiki::cfg{UseLocale} = 1; $TWiki::cfg{Site}{Locale} = 'da_DK.iso885915'; $TWiki::cfg{Site}{Lang} = 'da'; $TWiki::cfg{Site}{CharSet} = 'iso-8859-15'; $TWiki::cfg{Site}{FullLang} = 'da-dk';

-- SP

I do not know what the difference is in environment. Simply editing DocID1? (of format="1.0") on my site strips the form field content from the first double quote on; but editing DocID1? here on develop.twiki.org works as expected.

My enviroment:

* Linux 2.4.21-27.ELsmp #1 SMP i686 i686 i386 GNU/Linux * Perl v5.8.0 * {UseLocale} not set * $TWiki::cfg{Site}{Lang} = 'en'; * $TWiki::cfg{Site}{FullLang} = 'en-us'; * $TWiki::cfg{Site}{CharSet} = 'iso-8859-15';

-- PTh

I just tried it on a raw, out of the box, 4.0.0, default plugins only, and it works fine. I would guess that either:

  1. You have a hacked copy,
  2. You are running a plugin that has ideas of it's own.

If you can reproduce the problem, we should investigate further.



Re-opening since it is a bug on a plain vanilla Cairo installation that was upgraded to a plain vanilla Dakar.

-- PTh

Peter, you can do better than that. "It doesn't work" is not a useful bug report; it has to be reproduceable. Sorry, but I am discarding this until the report contains enough information to be able to reproduce the problem.

Some questions you need to answer:

  1. What does "plain vanilla" mean?
  2. Does "upgraded" mean "run through UpgradeTWiki"?
  3. Exactly what steps have to be performed to reproduce the problem?


Summary Form field content lost after "double quote"
ReportedBy TWiki:Main.PeterThoeny

SVN Range Thu, 02 Feb 2006 build 8675
AppliesTo Engine

Priority Normal
CurrentState No Action Required


TargetRelease n/a

Topic attachments
I Attachment History Action Size Date Who Comment
Compressed Zip archivezip tt.zip r1 manage 3.0 K 2006-02-10 - 20:39 PeterThoeny doc topic in 1.0 format and form topic
Edit | Attach | Watch | Print version | History: r12 < r11 < r10 < r9 < r8 | Backlinks | Raw View |  Raw edit | More topic actions
Topic revision: r12 - 2007-02-04 - CrawfordCurrie
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2023 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback