• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Using version 8347 of plugin in IE 6.

White space is being added in heading and other rows. This messes up the formatting done by TablePlugin. Most noticably the table heading are then not all recognised by TablePlugin or WysiwygPlugin.

Can you give a testcase please?


I tried to generate in the Sandbox Web, but the WYSIWYG editor wasn't working. See TestWysiwygWhiteSpaceTable. Is now, so I've given it another try. I got a very different error as you'll see in TestWysiwygWhiteSpaceTable1

JohnTalintyre - 27-Jan-2006

Here's some more useful information I've mentioned to generate that highlights the problem.

Create simple table and save using normal edit mode

$ more TestTopic5.txt | tail -4 | head -1 | od -c
0000000   |       *   a   *       |  \n
$ more TestTopic5.txt | tail -4 | head -1 | od -x
0000000 207c 612a 202a 0a7c

Now edit (no change) and save with WYSIWYG editor

$ more TestTopic5.txt | tail -4 | head -1 | od -c
0000000   |     240   *   a   * 240       |  \n
$ more TestTopic5.txt | tail -4 | head -1 | od -x
0000000 207c 2aa0 2a61 20a0 0a7c

So we've got extra characters of hex code a0 appearing, which appears as extra space.

I can't see anything wrong. I just:
  1. Visited TestWysiwygWhiteSpaceTable
  2. Edited (standard) it an copied the second table
  3. Edited (standard) TestWysiwygWhiteSpaceTable1
  4. Pasted in the table, saved
  5. Edited (Wysiwyg) TestWysiwygWhiteSpaceTable1
  6. Set the last column to "done"
  7. Saved
Looks OK to me. Firefox 1.0.4.

If you can be more specific about the problem, please re-open this report.


As stated above I was using IE 6. Also I can't reproduce this on this site because the WYSIWYG editor put undefined in the topic when I save. However, I have now tried Firefox 1.5 on my local site and that works fine. So IE 6 seems to be part of the problem.

I've temporarily fixed on our site for IE by adding a removal of \x0a to HTML2TML.pm:

$text =~ s/\xa0//g;

P.S. A fantastic piece of work. I did a bit of work some time ago and on a (much much) simpler Javascript editor in TWiki so I can appreciate what this has entailed.

I hope I've picked a correct CurrentState. -- JohnTalintyre - 27-Jan-06

The IE undefinedundefined problem is fixed; but I can't reproduce any problems with spaces being inserted. I don't see any inserted \xa0's either. I really need a step-by-step testcase that reproduces the problem using IE on this site, otherwise I'm guessing.....


I've moved our site to TWiki 4.0.1 and the above problem doesn't appear to be present. So perhaps this is a Cairo plus IE 6 problem !?

So it looks unlikely this problem can be reproduced on this site.

-- JohnTalinthyre - 9-Feb-06

Summary White space being added to tables
ReportedBy TWiki:Main.JohnTalintyre

SVN Range Wed, 25 Jan 2006 build 8511
AppliesTo Extension
Component WysiwygPlugin
Priority Normal
CurrentState Closed

TargetRelease major
Edit | Attach | Watch | Print version | History: r9 < r8 < r7 < r6 < r5 | Backlinks | Raw View |  Raw edit | More topic actions
Topic revision: r9 - 2006-02-09 - JohnTalintyre
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2023 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback